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Preface: 
 
Kerkythea is a standalone render engine, using physically accurate materials and lights, aiming for 
the best quality rendering in the most efficient timeframe.  The target of Kerkythea is to simplify the 
task of quality rendering by providing the necessary tools to automate scene setup, such as 
staging using the GL real-time viewer, material editor, general/render settings, editors, etc., under 
a common interface. 
 
Reaching now the 4th year of development and gaining popularity, I want to believe that KT can 
now be considered among the top freeware/open source render engines and can be used for both 
academic and commercial purposes.  In the beginning of 2008, we have a strong and rapidly 
growing community and a website that is more "alive" than ever! 
 
KT2008 Echo is very powerful release with a lot of improvements. 
 
Kerkythea has grown constantly over the last year, growing into a standard rendering application 
among architectural studios and extensively used within educational institutes.  Of course there are 
a lot of things that can be added and improved. 
But we are really proud of reaching a high quality and stable application that is more than usable 
for commercial purposes with an amazing zero cost!  
 
Ioannis Pantazopoulos 
January 2008 
 
 
Like the heading is saying, this is a Getting Started “step-by-step guide” and it’s designed to get 
you started using Kerkythea 2008 Echo. 
 
Of course it can be an advantage, but fact is that it’s not necessary that you have any experience 
with rendering software prior to getting aboard KT.  Many beginners find that they adapt very 
quickly. 
 
This guide will cover what we interpret as being the basics, which is essential to get you started. 
 
For more advanced settings, we advise you to visit our web-site at http://www.kerkythea.net and 
look through some of the other tutorials available. 
Some of the tutorials are videos and others are pdf-documents. 
 
Likewise, we also advise you to visit the KT Forum, where you can find many resources and useful 
tips and tricks posted by fellow KT users. 
In our Wiki you can also find answers to many of the questions you might have.  
 
 

IMPORTANT NOTICE! 
If this is the first time you’re rendering a model, we recommend that you start with a fairly simple 
model.  As the saying goes – You need to learn how to crawl before you can walk. 

 
 

http://www.kerkythea.net/
http://www.kerkythea.net/joomla/index.php?option=com_wrapper&Itemid=76
http://www.kerkythea.net/joomla/index.php?option=com_openwiki&Itemid=75
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1. IMPORTANT NOTES – SIZE MATTERS: 
 
Kerkythea is a wonderful physically accurate Global Illumination render engine (which in addition 
allows the user to use simple ray trace method for non photo-realistic rendering) but to use it right 
and get the most out of it without too much frustration, you need to follow physical laws and "real 
world" parameters!! 
 
One of the most important parameters is to ensure that your scene/model has the correct scale. 

1 KT square = 1 square meter 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If your scene/model is off scale, it will have a huge impact on the final rendered image. 
(with a scan line render engine it is not important but as soon as Global Illumination and physics 
are calculated, the scale of the scene becomes important.) 
 
For example:  If you want to illuminate your scene with a light source, the result will differ a lot if the 
light sources have a distance of 1 km vs. a distance of 5 meters. 
(the power of the light is different and light bouncing, indirect light is also different.) 
 
It is a matter of avoiding artifacts and poor renderings, which lead to frustration. 
Physics is integral to how the render engine works.   
 
The first "mistake" is to think that every render engine works more or less the same. 
A little bit of reflection, a bit of diffuse, maybe some refraction and specular and tada the material 
has been created. 
The above is true for simple ray tracer- or scanline- render applications, but not for Global 
Illumination render-methods like Phonton Mapping with Final Gathering (PM+FG) or unbiased 
render methods like Metropolis Light Transport (MLT), Bidirectional Path Tracing (BiPT), etc. 
Why? Because a simple ray tracer only renders "direct light". 
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2. MAKE SURE YOU HAVE WHAT IT TAKES: 
 
First of all please ensure that you have the latest version of Kerkythea installed. 
 
To check this in Kerkythea (KT) 
Click the Help > About Kerkythea... in the top right corner. 
 
In addition… 
Download and install as many of the material libraries available 
(At the time of writing this tutorial, there are 26 mat. libraries available in the KT repository) 
You can also find some nice material packs in the Material section of the KT Forum. 
 
After download you can install the material libraries in KT.  (see item 2 on next page) 
 
We also recommend that you download some Globals. 
Globals are spherical images of skies which may include a sun setting, which you easily can apply 
to your scene. 
 
To install the Global libraries, you use the same procedure as used for material libraries. 
 
Finally you can download some of the Model libraries we've made available. 
 
Currently there are 5 libraries available containing some Xfrog trees, a Grass model library, some 
3D Flowers, Cars and finally a model library containing Fritz Hansen Chairs... 
 

IMPORTANT NOTICE! 
Please note that some of the model libraries made available needs to be unzipped unzip the files 
to where your KT Models sub-folder is located. 
(I.e. X:\Program Files\Kerkythea Rendering System\Models) 

 
 
In this tutorial we will use a scene, which you can download from here. 
The file-name is Getting-Started-Scene-XML.zip 
It’s not required that you use this scene, but if this is one of the first times you are using a render 
application it might be easier for you to follow this tutorial and learn the basics of rendering. 
 
This scene/model has also been used in the Beginners Starting Guide thread at the KT Forum, and 
you might find some useful information in that thread, where users have been asking question 
along with the guidance. 
 
A short note on the KT files. 
You might have noticed that some models have the extension "XML" and others "KZX". 
 
The XML file is a standard XML file native to Kerkythea and the "KZX" is a zipped version of the 
XML-file (Kerkythea Zipped XML), enabling you to save space on your hard drive. 
 
If you have a huge XML-scene, you can compress it by using your favorite zipping application and 
then rename the file-extension .ZIP to .KZX. 
KT2008 Echo is able to open both formats. 
 

http://www.kerkythea.net/joomla/index.php?option=com_remository&Itemid=42&func=select&id=2
http://www.kerkythea.net/joomla/index.php?option=com_remository&Itemid=42&func=select&id=3
http://www.kerkythea.net/phpBB2/viewforum.php?f=19
http://www.kerkythea.net/joomla/index.php?option=com_remository&Itemid=42&func=select&id=11
http://www.kerkythea.net/joomla/index.php?option=com_remository&Itemid=42&func=select&id=17
http://www.kerkythea.org/users/frederik/tutorials/Getting-Started-Scene-XML.zip
http://www.kerkythea.net/phpBB2/viewtopic.php?t=4863
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3. INSTALLING KT MATERIAL AND GLOBAL LIBRARIES: 
 
To install the KT Material and Global libraries click 
1.)  File > Install Library... 
 

2.) Select the folder where you have downloaded the .mat.zip 
files to and select all by holding down the Shift key on your 
keyboard just as you would if you want to select multiple 
files anywhere else. 

 
 

 
 
 
 
 
 
3.) Hit the OK button. 
 
 
 
Please note that it will take some time for all the material libraries to install, but a window will pop-
up informing when the libraries have been installed successfully. 
 
 
 
An alternative method … 
 
1.) From the menu Click Settings > Materials… 
 
 

  
 
2.) In the right panel of the Material Workshop below “Current Library” click the Open button. 
 
 
 
 
 
3.)  Click the Import button  
 
 
 
 
 
 
4.) Select the Material libraries you want to install and click OK. 
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4. A QUICK OVERVIEW OF THE GUI (Graphical User Interface): 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

At the top you have the menu-bar and below that you have the icon-bar. 
 
Below the menu-bar you find the icon-bar with easy access to the most common tasks. 
 
To the left you have the Scene Tree View 
 
The center window shows the scene/model. 
 
Quick view of your rendered image (shows only while rendering). 
 
Material Browser 
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5. THE ICON-BAR: 
Material Reset Perspective/  

Bottom(4)
Back (5) Right (6) Start 

Render
Stop/ Redo Rotate/Orbit 

Open Save image  Roll (R) Editor (M) View(E) Parallel North East Abort (Ctrl-Y) (Q) 

If you place the arrow on one of the icons a small text box will appear helping you to identify the 
purpose of the icon. 
 
Icon Description Used to… 

 Open Open your scene/model file. 

 Save Scene Save your scene and settings (applied materials, lights etc.) 

 Save Image Save the image you have rendered. 

 Undo Undo command 

 Redo Redo command 

 Hide Hide a selected material, group or light. 

 Material Enter the Material Editor of a selected material 

 Select Select tool 

 Rotate/Orbit Rotate/Orbit the scene/model. (Drag Center Mouse Button) 

 Pan Pan the scene/model.  (Drag Right Mouse Button) 

 Roll Roll the scene/model.  

 Dolly Zoom the scene/model. 

 Reset Reset the view of the model to origin. 

 Camera/Cycle To switch between the cameras you’ve applied in your scene. 

 Perspective/Parallel To switch between Perspective (3D) and Parallel (2D) view. 

 Top View scene/model from top. 

 Bottom View scene/model from bottom. 

 Front (South) View scene/model from front side. 

 Back (North) View scene/model from back side. 

 Left (West) View scene/model from Left side. 

 Right (East) View scene/model from right side. 

 View Image Open the rendered image window. 

 Start Render Start the render process. 

 Pause Render Pause a render in progress.  

 Stop Render Stop/Abort a render in progress 
 

                                                                          

 

                                                       
Save Scene   Undo  Hide(H) Select  Pan(P) Dolly/Move Camera/     Top (1) Front (2) Left (3) 

West 
View Pause 

South Camera(W) Cycle (C) Image Render   (Ctrl-Z) 
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6. OPENING YOUR SCENE/MODEL: 
 
Open KT 2008 and open the scene/model you want to render. 
KT2008 supports the following 3D File Formats: 
3DS, OBJ, XML (Native KT format) and KZX (Zipped KT XML format) 
 
1.) From the menu click File > Open or press Ctrl + O on your keyboard 
 
2.)  Select the file containing your scene/model and click the OK button. 
 Wait until the scene/file has been completely opened. 
 
 
 
 
 
You can switch between “wire frame” or “Solid” view, by hitting the “V” on your keyboard. 
 

   
 
Or by selecting View > Adjust > “Wireframe Rendering” or “Solid Rendering” 
In addition to the standard Wire-frame, you can also select a colored wire-frame. 
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7. THE MERGE FUNCTION: 
 
With KT you can add a model or update your existing scene/model. 
 
To add a new model to your scene you simply… 
 
1.) Click File > Merge from the menu-bar.  
 

A new Open Settings window will open and enable you 
to set-up the merge function of exactly what you  
want to merge into your scene. 

 
 
 
 
 
 
 
 
 
 
 
 
 
The merge options shown above should be fairly self-explanatory. 
 
Models: Merge – Add New To Current  
(Used if the model you want to merge with the current open scene contains an entirely new model you want to add) 
(Merge > Replace Mesh would keep your current KT material settings, and update only the geometry of that material.) 
 
Lights: Merge - Add New To Current  
(Used if your new model contains light sources like Omni-, Spot- or Self luminance –lights which you want to add to the scene.)  
 
Cameras: Keep Current - Throw Away New.  
(Used if the model you want to merge with the current open scene contains new camera positions, but you prefer to not import them.)  
 
Global Settings:  Keep Current - Throw Away New  
(Used if the model you want to merge with the current open scene contains a special Global setting you do not want to use, this will 
retain your current scene’s sun/global settings)  
 
Render Settings:  Keep Current - Throw Away New  
(Used if the scene/model you want to merge with the current open scene contains special render settings which you would rather not 
import) 
 
The best advice we can give you will be for you to play with the merge option creating simple 
merging scenarios to see “what if”. 
 
Once you've set the settings, you can click the OK button. 
A Merge Scene window will open enabling you to select the file you want to merge with the 
scene/model already open. 
 
Once you have selected your file, click the OK button.  
The new scene will be merged with your existing scene and now you can apply and/or adjust the 
materials of the new components. 
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8. FINDING MATERIALS IN YOUR MODEL/SCENE: 
 
In KT, objects are defined ONLY by their material name… there are no independent ‘objects’ or 
‘layers’ 
You can select a material from the Scene Tree View. 
However, it can be difficult to recognize the materials once they are imported into KT. 
 
By using the Select tool in KT, you can click on any object in your model/scene, and the 
corresponding material will be highlighted in the material list. 
 

  
You can also double-click the name in the material list and the corresponding object in your 
model/scene will be highlighted. 
 
Once you know the name of the material, you can change or apply a new material. 
 
To de-select the material you can click another area of the model/scene or by double-clicking the 
highlighted material in the material list.  Or you may right-click and choose ‘Unselect’. 
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9. APPLY/AMEND MATERIALS: 
 
As mentioned in the preface, this is a Getting Started tutorial meant to get you started with 
Kerkythea and the process of making photorealistic renders of your 3D models and scenes. 
We won’t spend time on material creation in this tutorial but if you are interested in this area, we 
recommend that you download the material tutorial and visit the KT Forum for further and deeper 
understanding on this subject. 
However, although the Material Editor can appear very confusing at first glance, it’s actually very 
user-friendly and logical in the design. 
 
 
 
 
 

Material Preview window: 
Move the slider to rotate the 
preview scene. 
Click the magnifying glass to zoom 
Click the preview to apply a 
material from one of the installed 

Reflectance: 
Used to set your material 
appearance. 
You can use bitmaps or select 
colors. 

Self Luminance: 
Used to create light materials 
In the Radiance channel you 
can use bitmaps or colors. 

Material Preferences: 
Used to set preference of the 
material. (I.e. Thin Glass, 
Anisotropic, Layered mat. etc.) 

Material List: 
List of materials used in the open 
scene/model.  Select the 
material you want to edit from 

Texture Editor: 
Used to apply texture settings. 

Transmittance: 
Used to set/adjust your material 
transmittance settings. 
(I.e. translucency, refraction etc.) 

Bump Mapping: 
used to produce the appearance of 
depth, or "bumps". 
You can use bitmaps or colors. 

Bevel Mapping: 
Gives the edges the appearance 
of being bevelled (receeding 

Clip Mapping: 
Used as a method of clipping (cutting) holes 
or an outline of a material. 
You can say that Clip-maps are similar to 
alpha maps in a bitmap.  They act as a ‘mask’ 
revealing only the parts you wish to reveal.  
Black hides, white reveals. 
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9. APPLY/AMEND MATERIALS: (continued) 
 
If you want to apply a material from one of the material libraries you have downloaded (or perhaps 
made yourself), simply… 
 
 
 
 
 
1.) Right-click the material 
 
 
2.)  Select Apply Material in the sub-menu. 
 
 
3.) Select the material from one of the 
 material libraries you have installed. 
 
 
4.) Click the material of your choice. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

IMPORTANT NOTICE! 
If you have applied good textures in your favorite modeling application, you will discover that 

many of the materials in your scene do not need to be changed. 

 
 
 
For those who want to have an overview of all materials used in a scene, KT offers an alternative 
to the above. 
 
1.) From the menu-bar click Settings > Materials… 
 This will open the Material Workshop window 
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9. APPLY/AMEND MATERIALS: (continued) 
 
2.)  In the Scene Materials Panel you will find a list of all 

the materials your scene/model contains. 
Right-click and select Select All 

 
3.)  Select one or multiple materials, then right-click and 

select Rebuild Selected 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

After a while all materials have been rebuilt and the 
scene materials will look something like the image to 
the left. 

 
 
 

  
In the “Current Library” click the Open button and select 
one of the material libraries and click OK 

 
 
 
 

 
 
 1.) In the Scene Material window 
 Select (click) the material you 
 want to change. 
 
2.) In the Current Library window 

Select (click)the material you 
want to apply. 

 
3.) While pointing at the material 

you want to apply, right-click 
and select the Apply to Left 
Pane. 
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10. WORKING WITH MATERIALS: (CHANGE THE COLOR) 
 
Apart from the Material tutorial, you can learn much about material creation by investigating some 
of the materials found in the material libraries. 
 
Although we will not go deep into material creation in this tutorial, we will give you some examples 
of how to change and make a couple of materials. 
 
You can easily change the color directly in KT.  There’s no need to do such in whatever modeling 
application you use. 
 
The steps to change a color are. 
 
1.) Select the material from the Scene Tree View or by using the Select tool. 
 
2.) Right click the material name in the Scene Tree View 

and select Edit Material from the sub-menu. 
 
3.) In the Diffuse channel you can see the color already used, now click on the square color 

and a new Select color window will open, from where you can select a new color. 
(Please note that you have 5 tabs in the Select Color window which are the different methods to select a color...)  

 
4.) After having selected a color click the Accept button in the Select Color window. 
 
5.) Click the Apply Changes button and click the Close Editor button...  

 
 
 
 
 
 
 
 
 
 
 
 

  
 
And voilà - you've applied a new color. 
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10. WORKING WITH MATERIALS: (USE BITMAP) 
 
 
 
 
1.) Select the material from the Scene Tree View or by using the Select tool. 
 
2.) Right click the material and select Edit Material from the sub-menu. 
 
3.) In the Diffuse channel you can see the color already used. 

Right-click while pointing at the name “Diffuse”. 
Click the Clear (Delete) button 

 
4.) Once again right-click while pointing the name “Diffuse”. 
 Click the Add Bitmap button 
 

 
5.) If the bitmap you want to use is already in use in your scene, you simply click it. 

If it’s not click the Browse button and select the bitmap you want to use. 
(KT will recognize .png, .jpg, .bmp files for the bitmap) 

 
6.) Click the Apply Changes button and click the Close Editor button.  
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10. WORKING WITH MATERIALS: (SCALE BITMAP) 
 
 
 
 
 
 
1.) Select the material from the Scene Tree View or by selecting it using the Select tool. 
 
2.) Right click the material and select Edit Material from the sub-menu. 
 
3.) If you have applied a layered material, click one of the layers in the Material Preference to 

locate the bitmap in the Diffuse channel. 
 
4.) Click the word Diffuse and click the bitmap in the Texture Editor. 
 

 
 
5.) In the Coordinates box you can adjust the X and Y scale. 
 
6.) Click the Apply Changes button and click the Close Editor button.  
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10. WORKING WITH MATERIALS: (TRANSPARENT MATERIAL) 
 
 
1.) From the test scene Select the lamp-shade material from the Scene Tree View 

or by selecting it using the Select tool.  (In the test scene the material name is: Color_K18) 
 
2.) Right click the material and select Edit Material from the sub-menu. 
 
3.) In the Diffuse channel you can select a color or apply a bitmap as explained previously. 
 
4.) Right-click while pointing at the word Refraction and select Add Color. 
 
5.) Select a grey color (White = 100% transparent, black = 0% transparent.) 
 
6.) Make sure that Index of Refraction is set to 1.000 
 

 
 
7.) Click the Apply Changes button and click the Close Editor button.  
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10. WORKING WITH MATERIALS: (CREATING A MIRROR MATERIAL) 
 
 
1.) Select a material from the Scene Tree View 

or by using the Select tool. 
 
2.) Right click the material in the Scene Tree and select Edit Material from the sub-menu. 
 
3.) Right-click the word in the Material preference and select Set Dielectric / Glass. 
 
4.) Right-click while pointing at the word Reflection and select the Add Color. 
 
5.) Select a White color 
 
6.) Un-tick the Fresnel box 
 

 
 
7.) Click the Apply Changes button and click the Close Editor button.  
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10. WORKING WITH MATERIALS: (SELF LUMINANCE/FAKED LUMINANCE) 
 
1.) Select a material from the Scene Tree View 

or by using the Select tool. 
 
2.) Right click the material and select Edit Material from the sub-menu. 
 
3.) Right-click while pointing at the word Radiance in the Self Luminance box. 
 
4.) Select a White color. 
 
5.) Adjust the Efficiency according to your needs. 
 
6.) In the test scene example, you can un-tick the Emitter box, since we don’t want it to emit 

light, but only need to make a visual effect of a built-in spot light. 
 

 
 
 
7.) Click the Apply Changes button and click the Close Editor button.  
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10. WORKING WITH MATERIALS: (SELF LUMINANCE- continued) 
 
 

IMPORTANT NOTICE! 
 
When using self luminance materials, it’s worth mentioning that you need to apply it with caution! 
 
Light bulbs have a spherical shape in “real life”, but avoid the use of spherical shapes if you want 
to apply a self luminance material! 
 
If you apply a self luminance material to a sphere the render time will increase considerably, 
since the spherical shape needs to build up substantial numbers of triangular mesh faces and 
the render time will be analogous to the number of triangles. 
 
Instead we recommend that you only apply self luminance material to square- or triangular- 
shapes. 
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11. UV MAPPING: 
 
Some users experience that some textures looks distorted after having applied a new material. 
 

There is nothing wrong with the texture itself. 
This is caused by missing UV coordinates and is 
typically occurring if only a color and not an image 
texture have been applied to a surface in the 
modelling application before export. 
 
UV Mapping (UV) refers to the process of assigning 
3D objects with dimensions X, Y and Z mapping 
coordinates like a 2D plane with coordinates U and V.  
Texture images require this step because it tells the 
program how to apply a 2D image map onto a 3D 
object. 
Sometimes there are some workarounds though.  

As a workaround, in some flat models, you can set the Projection to Cubic in the Bitmap 
Options. 
 
1.) If you have applied a layered material, click each layer in the Material Preference until you 

locate the bitmap (typically) in the Diffuse channel. 
 
2.) Click the title for the “Diffuse” channel and click the bitmap image in the Texture Editor. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3.) Select the Projection drop-down menu and click the appropriate form. 

 

(typically Cubic will work best in most situations) 
 
4.) Click the Apply Changes button and click the Close Editor button.  
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12. THE GIZMO: 
 
As you've learned previously, you can select materials by clicking the objects directly using the 
Select tool or by selecting the materials in the Scene Tree View.  
 
You will also notice that the Gizmo will appear when selecting materials and with the Gizmo you 
can move objects around. 
 
By clicking the arrows of the Gizmo using the Select tool you can drag the selected material/object 
in the X, Y and Z directions where the arrows are pointing and you can also rotate it. 
 
The Gizmo has a couple of other functions. 
If you click the View > Gizmo from the menu-bar you can see the options in the sub-menu. 
 

   
Translate/Rotate 

(default option) Translate/Move Scale 

 
If you have selected a material/object, you can press the G-key on your keyboard to toggle 
between the above Gizmo options. 
 
If you want to scale an object, you can do this in the X, Y and Z directions, but this will usually not 
be very useful. 
However, if you use the Select tool and point at the center part of the Gizmo you will select the 
XYZ axis at the same time, which makes it much easier to uniformly scale an object. 
 
 

IMPORTANT NOTICE! 
The Gizmo is a very nice feature, but be careful when you use it.  
It's very difficult to place the objects correctly - but with some practice, it can be done. 
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13. SOME WORDS ABOUT LIGHT SETTINGS: 
 
Lighting is the key to make the viewer believe it to be about a realistic scene. 
One of the most difficult parts of making a photo realistic render, is to set-up the lightning of an 
interior scene/model. 
This is what most people are struggling with and where many – unfortunately - give up. 
Giving a general advice about the light settings is very difficult, because it all depends on the 
scene/model, the size of the scene/room, the materials used etc. Nevertheless, we will try to give 
you some ideas of “standard” settings and how you can adjust it. 
  
The best advice to start lighting a scene, is to only place lights where they would actually go in real 
life.  A common error is to put omnis floating in the middle of rooms. Kerkythea will bounce the light 
around for you, so put lights where they belong, and let KT do the work. If you have placed lights 
everywhere they would go in real life, and the scene is still too dark, remember to increase the 
exposure of the image. 
In addition…One of the best guides we can give you is that you need to think that rendering in KT 
is very similar to taking a photo. 
I.e. if you want to take a photo of a room, you wouldn’t just light it up using a single light bulb. 
 
A proffessional photographer is also struggling when setting up lights in a real environment. 
They constantly need to be very creative with illuminating a scene. 
They set-up hidden lamps, use reflectors etc, something that we - as viewers - don’t see in the final 
shot in a magazine. 
 
But you can set-up the lighting exactly like a photographer will do it. 
You can even create your own basic light studios. 
 
 
 
 
 
 
 
 
 
 
 Example of Basic Light Studio 
 
 
At the KT Forum you can get some good 
ideas of how to be creative with setting up 
lights in your scene/model for interior shots. 
 
You will need to experiment with pointlights, 
spotlights and self-luminance lightning  
before you master it. 
 
On the next pages you will learn more 
about point, omni, and spotlights, 
how to set them up and how to adjust 
the settings. 
 

http://www.kerkythea.net/joomla/index.php?option=com_wrapper&Itemid=76
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14. POINT AND SPOTLIGHT SETTINGS: 
 
1.) Select a light source from the Scene Tree View. 

or by selecting it using the Select tool. 
 
If you adjust the view to be looking exactly where you want a light to be, you can place a light 
inside of KT using Insert > Spotlight.  It will be placed at the current point of view. 
 
2.) Right click and select Edit Light from the sub-menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For Pointlights you can only adjust the Multiplier value and the color (Radiance). 
For Spotlights you also have the option to adjust the Hot Spot (angle of the radius of the bright spot 
in the middle) and Fall Off (angle of the radius of softening from Hot Spot power to zero) settings. 
In the Scene Tree view you right-click your light and select Disable in the sub-menu to turn the 
selected light off or Enable to turn it on. 
If you Disable a light you will notice that the small light bulb in front of the name will be marked 
with a red cross, enabling you to see which lights have been turned off or on. 
You can edit multiple lights in one go if you group them and edit the main light of the group.  Or to 
Enable many at once, select multiple lights at once and choose ‘Enable’ or ‘Disable’. 
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15. SUN & SKY WIZARD: 
 
In Kerkythea the Physical sky simulates a real-world Physical sky for any location, date and time.  
The sky will contribute light to your scene just as a sky will do in real life.  (the sky will not 
contribute light when using Raytracing render settings) 
 
You can Edit the sun light exactly the same way as you have learned how to edit point and 
spotlights. But to edit the location, date and time you need to… 
 
1.) From the file menu click Settings > Sun and Sky… 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2.) The Location, Date and Time should be identical to 

what you’ve applied in SU. 
If you’re not satisfied with the settings, you can 
Change them now. 

 
 
 
2.) Select the location, date of the year and time of the day and click the Next button 
 
3.) Select the Sky Type to be Physical Sky and click the Finish button. 

(If need be, you can change the Intensity and the Turbidity, but it is recommended to leave these as default!) 
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16. APPLYING A GLOBAL STUDIO: 
 
In the KT repository you can download some Global Studio libraries. 
These are made to make it much easier for you to apply a spherical image of i.e. a sky, which will 
give your exterior renders a much more realistic feeling. 
 

1.) From the File menu click Insert > Globals and select the library and global you want to 
apply to your scene. 

 
Please note that it will be loaded into your scene automatically. 
 
Some globals may be designed to change your sun settings.  So be sure to have a file saved with 
your sun settings to merge back into your scene if the sun position is important. 
 
 

 
 
 
 

http://www.kerkythea.net/joomla/index.php?option=com_remository&Itemid=42&func=select&id=11
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17. HOW TO APPLY SPHERICAL SKY IMAGES: 
 
Apart from using Global libraries, you can get some really nice and free spherical sky bitmaps on 
the Internet.  Here are some examples: 
BlenderArtists.org, Evermotion or Continuum Skies. 
 
 
 
 
1.) Click Settings > Sun and Sky… 
 
2.)  Select the location, date of the year and time 

of the day and click the Next button. 
 

 
 
 
 
 
 
 
 
 
3.)  In Sky Type select Spherical Sky 
 
 
 
 
 
 
 
 
 
 
 
 
4.)  Click on the box next to Map/Color  
 
5.)  Click the Browse button and select your 

spherical Sky-images. 
(JPG's or HDRI-files are supported) 

 
6.)  Select a file and click OK. 
 
 
 
7.)  Click the Finish button to finalize the Sun & Sky Wizard. 
 
 
 
 

http://blenderartists.org/forum/showthread?t=24038
http://www.evermotion.org/index.php?unfold_exclusive=84&unfold=exclusive
http://www.lfgrafix.com/grafix/Skies_Free/SkyBasic-2.html
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18. INSERTING A MODEL FROM A KT MODEL LIBRARY: 
 
In the KT repository you will find some Model libraries available for you to download. 
Currently we have 5 model libraries containing some Xfrog trees, a Grass model library, some 3D 
Flowers, Cars, and finally a model library containing Fritz Hansen Chairs. 
 
These are made to make it much easier for you to insert a high poly model in your scene, where 
materials already have been applied. 
Download the libraries and unzip the models as described. 
 
1.) From the File menu click Insert > Model and select the library and model you want to apply 

to your scene. 
 
Be aware that some models can be very large and may take some time to finish loading. 
 

 
 
2.) Once the model has been imported to 

your scene, it will be found typically at  
KT’s axis origin. 
You can move it by selecting the model in the Scene Tree View and using the Gizmo to 
place it wherever you desire. 

 
 

http://www.kerkythea.net/joomla/index.php?option=com_remository&Itemid=42&func=select&id=17
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19. USING THE INSTANCING BRUSH: 
 
Click here to watch the online Instancing Brush Video Tutorial.  
 
 
 
 
 
 
 
 

 
 

http://www.kerkythea.net/joomla/index.php?option=com_openwiki&Itemid=75&id=instancing_brush_tutorial
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20. START RENDER: 
 
1.) Click the Start Render icon. 
 
2.) Select the Camera to render. 
 
3.) Select the Resolution. 
 
4.) Select the render Settings / Render presets 
 
5.) The Threads refer to the number of 

processors you have on your computer. 
 
6.) If your computer is connected to a network 
 you can set-up a render farm. 
 
7.) Click the OK button to commence. 
 
 
 
Note that you can overwrite the predefined resolutions and manually type in any output resolution.  
For instance, you may highlight “800x600” and enter “4000x2600” 
 
You can stop the render process at any time.  In the initial test phase you don’t need KT to 
complete the render process.  It is recommended that you should leave ‘Render in Background’ 
checked at all times, this puts the rendering process at a lower priority so you can still work in other 
applications while you render.  This will not noticeably slow down your rendering times. 
 
What you will find out in this initial render is what parts you need to adjust.  So it is wise to use 
lower render settings for initial tests, and slowly increase quality as you go along. 
It might be that you need to change some of the materials used or in/de-crease the light power. 
 
Click the Image icon to view the rendered image in the full resolution you’ve selected. 
 
 
To Save the image, click Save 
 
If your scene is very dark, you 
Can adjust the Exposure and 
Gamma settings. 
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21. SHIFTING BETWEEN CAMERA POSITIONS: 
 
In some modeling applications you can save a view of an angle you like to use as reference for a 
camera position and the plug-in can automatically export this view as a camera position in KT. 
I.e. with Google SketchUp a scene will get exported as a camera position if you’re using the 
SU2KT plug-in.  This is the same with Blender2KT, and others. 
 
However, you can also select a camera position in KT. 
Once you have found an angle you like, you can place a 
camera at the exact position you are viewing. 
 
From the file menu click Insert > Camera. 
 
In the Scene Tree View you can see a list of camera 
positions in your scene. 
 
If you right-click while pointing at one of your camera 
positions, you can select Edit from the sub-menu and here you can edit the Resolution, Film 
Height, Focal Length etc. 
(If you are familiar with photography, KT supports physical camera settings) 
 
You can also update the camera position by either selecting or moving it, or by viewing from it 
(GoTo/Follow command) and pressing “U”. 
In the latter case, you mount the camera and by making adjustments to the viewer the camera 
follows your changes. You can unmount the camera by pressing again “U”. 
 
You can click the Camera/Cycle tool to toggle between the camera positions in your scene/model. 
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22. CHOSE THE RENDER PRESET: 
 
The list of pre-defined render settings is immense and containRay, PhotonMap (GI), Path Tracing, 
Bidirectional Path Tracing (BiPT), Metropolis Light Transport (MLT), Clay, Mask and many others. 
 

 
 
Biased techniques (Ray Tracing and Photon Mapping) are usually much faster, because the 
estimation has been optimized so that a large part of the image is interpolated between key points.  
This might lead though to disturbing artifacts known as blotches on lower settings in some scenes. 
 
Unbiased techniques on the other hand take much longer but typically solve more accurately for all 
light interactions.  The artifacts in their case appear in the form of noise that is decreased over 
running time (known as “render passes”). 
 
To begin with we suggest that you play with the various types of render settings. 
 
Unless your scene is very complex and detailed, we suggest that you use preset no. 3 
PhontonMap – Quick to make your test renders and when satisfied with applying materials, lights 
etc., you can try one of the higher settings. 
 
The most common mistake of beginners is using too high of settings and getting frustrated with 
long render times. 
 
KT has been finely tuned to give good results even with lower settings. 
Only go higher as required by your scene. 
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23. RENDER METHODS: 
 
Photon Mapping  

+ Much faster evaluation/rendering of diffuse inter-
reflection due to interpolation. 

- In high complexity scenes some detail may be lost. 

+ The only method that can show caustics from point light 
sources through a perfect mirror.  PT, BiPT, MLT fail to 
evaluate these transfers. 

- Blotches may appear due to low sampling rates.  Render 
must be restarted in that case with higher sampling rates 
resulting in longer render times. 

Use it when: 

Rendering medium complexity scenes where a fixed amount of photons can distribute lighting equally at all places of the 
scene.  Details are usually lost when the scene complexity grows higher and higher, or when lit using mostly indirect 
light. 

 
Path Tracing  

+ Good with few lights directly lighting a scene.  (building 
exteriors lit with a sun) 

- Difficult to sample caustics.  

+ Good when lighting is uniform.  - Unable to sample caustics from point light source.  

Use it when: 

Rendering landscapes or objects under uniform sky lighting, and a distant light source (like a sun). 

 
Bidirectional Path Tracing  

+ Good with interior lights where lights are directly 
contributing to the scene.  

- May spend a lot of time sampling light paths which may 
not finally contribute, such as distant lights like a sun.  

+ Able to render caustics from point light sources and 
generally better to render caustics from light sources.  

- May take a lot of time in shadow rays & path densities 
computation where transfer happens only from a small 
percentage of links. 

Use it when: 

Rendering interiors with interior lighting or when the number of lights high. 

 
Metropolis Light Transport (MLT) 
This technique is a way to perform sampling given a primary sampling technique like PT or BiPT. 

+ Good indirect (difficult) lighting evaluation, since more 
samples are spent for difficult sampling cases.  (cases 
where lighting bounces through mirrors or is refracted)  

- Worse at sampling direct lighting due to worse 
stratification from PT/BiPT performed alone.  
 

+ Good caustics evaluation (MLT on top of PT is unable 
though to sample caustics from point light sources). 

- Worse at sampling uniform lighting scenes like 
landscapes under uniform sky lighting and distant sun.  

+ Effective mechanism for removing fireflies (white dots 
appearing in PT/BiPT alone).  

 

Use it when: 

You want to render scenes with difficult indirect lighting that contain many refracting & reflecting surfaces or many lights. 
Rooms that are lit basically indirectly by sun light can also be rendered faster by using MLT. 

 



       
 GETTING STARTED

 

Ver. 1.01 © Kerkythea 2008 Echo 
GETTING STARTED 

Written by: The KT Team 

Date: April 24th, 2008 
Page 35 of 41 

 

 

24. KERKYTHEA GLOSSARY: 
 
From Wikibooks, the open-content textbooks collection 
 

A 
Alpha Channel  Alpha Channel is information about pixels stored in images. 

This concept enables the storing of transparency information in images. 

Ambient Light  Ambient Light is light that doesn't seem to come from a specific source, but is 
just there.  Look under the desk - it's pretty dark, but there's some light there.  
In the real world, this is caused by stray photons bouncing around and 
occasionally ricocheting under the desk.  Ambient light is basic, minimal 
amount of light in the whole scene.  Adding too much ambient light makes a 
scene look washed out.  Since the light doesn't come from anywhere, all 
sides of an object are illuminated equally, and it won't have any shading on it. 

Ambient 
Occlusion 

Ambient Occlusion (AO) is a ratio of how much ambient light a surface point 
would be likely to receive.  It simulates a huge dome light surrounding the 
entire scene.  If a surface point is under a foot or table, it will end up much 
darker than the top of someone's head or the tabletop. 

Anti-Aliasing 
(AA) 

The process of averaging between pixels of different colors.  This result is a 
smoother, more blended transition between the edge of two areas rather than 
a distinctly jagged appearance. 

 

B 
Bevel mapping A beveled edge refers to an edge of a structure that is not perpendicular (but 

instead often at 45 degrees) to the faces of the piece.  The words bevel and 
chamfer overlap in usage; in general usage they are often interchanged, while 
in technical usage they may sometimes be differentiated as shown in the 
image at right. 

Bézier  Bézier surfaces were first described in 1972 by the French engineer Pierre 
Bézier who used them to design automobile bodies.  Bézier surfaces can be 
of any degree, but bicubic Bézier surfaces generally provide enough degrees 
of freedom for most applications. 

Bump mapping Bump mapping is a technique where at each pixel, a perturbation to the 
surface normal of the object being rendered is looked up in a texture map and 
applied before the illumination calculation is done.  Bump Mapping use a 
gray-scale image map to change the direction of surface normals.  You can 
use this to simulate height, so that you can paint wrinkles and bumps.  
50 % grey means neutral (no change is made), lighter means higher, darker 
means lower.  Note that the position of faces is not actually changed; by 
rotating just the normals, lighting will change too, to give the illusion of a 
height difference.  This has downsides too: the outline of objects isn't 
changed, so the trick is given away. 

 

http://en.wikipedia.org/wiki/Alpha_compositing
http://en.wikipedia.org/wiki/Ambient_light
http://en.wikipedia.org/wiki/Ambient_occlusion
http://en.wikipedia.org/wiki/Ambient_occlusion
http://en.wikipedia.org/wiki/Anti_aliasing
http://en.wikipedia.org/wiki/Anti_aliasing
http://en.wikipedia.org/wiki/Bevel
http://en.wikipedia.org/wiki/B%C3%A9zier_surface
http://en.wikipedia.org/wiki/Bump_mapping
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C 
Caustics  Caustics in optics is a bundle of light rays.  For example a caustic effect may 

be seen when light refracts or reflects through some refractive or reflective 
material, to create a more focused, stronger light on the final location.  Such 
amplification, especially of sunlight, can burn — hence the name.  A common 
situation when caustics are visible is when some light points on glass.  There 
is a shadow behind the glass, but also there is a stronger light spot.  
Nowadays, almost every advanced rendering system supports caustics.  
Some of them even support volumetric caustics.  This is accomplished by 
raytracing the possible paths of the light beam through the glass, accounting 
for the refraction, reflection, etc. 

 

D 
Depth of Field 
(DOF) 

Depth of Field (DOF) is the distance in front of and behind the subject which 
appears to be in focus.  For any given lens setting, there is only one distance 
at which a subject is precisely in focus, but focus falls off gradually on either 
side of that distance, so there is a region in which the blurring is tolerable. 
This region is greater behind the point of focus than it is in front, as the angle 
of the light rays change more rapidly; they approach being parallel with 
increasing distance. 

Diffuse mapping  Diffuse reflection is the reflection of light from an uneven or granular surface 
such that an incident ray is seemingly reflected at a number of angles.  It is 
the complement to specular reflection.  If a surface is completely nonspecular, 
the reflected light will be evenly spread over the hemisphere surrounding the 
surface (2π steradians). 

Displacement 
Mapping  

uses a greyscale heightmap, like Bump Mapping, but the image is used to 
physically move the vertices of the mesh at render time.  This is of course 
only useful if the mesh has large amounts of vertices, but the (relatively) new 
"Simple Subdiv" subsurf option allows you to add more vertices at render time 
which will be moved by the displacement.  This makes it much slower than 
Bump Mapping, as there need to be many more faces to render, but it is 
much more realistic. 

 

E 
Edge Outline  
 

http://en.wikipedia.org/wiki/Caustic_%28optics%29
http://en.wikipedia.org/wiki/Depth_of_field
http://en.wikipedia.org/wiki/Depth_of_field
http://en.wikipedia.org/wiki/Diffuse_interreflection
http://en.wikipedia.org/wiki/Displacement_Mapping
http://en.wikipedia.org/wiki/Displacement_Mapping
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F 
Focal Length  Focal Length of a lens is the distance along the optical axis from the lens to 

the focus (or focal point).  The inverse of a lens' focal length is called its 
power. 

Fresnel Fresnel lens is a type of lens invented by Augustin-Jean Fresnel.  Originally 
developed for lighthouses, the design enables the construction of lenses of 
large size and short focal length without the weight and volume of material 
which would be required in a lens of conventional design. 

 

G 
Global 
Illumination (GI) 

Global Illumination (GI) is a superset of radiosity and ray tracing.  The goal is 
to compute all possible light interactions in a given scene, and thus obtain a 
truely photorealistic image.  All combinations of diffuse and specular 
reflections and transmissions must be accounted for.  Effects such as colour 
bleeding and caustics must be included in a global illumination simulation. 

 

H 
High Dynamic 
Range Image 
(HDRI)   

High Dynamic Range Image (HDRI) is a set of techniques that allow a far 
greater dynamic range of exposures than normal digital imaging techniques. 
The intention is to accurately represent the wide range of intensity levels 
found in real scenes, ranging from direct sunlight to the deepest shadows. 
The use of high dynamic range imaging in computer graphics has been 
popularized by the work of Paul Debevec. 

 

I 
IES The IES data format is an internationally accepted data format used for 

describing the light distribution of luminaires.  It can be used in numerous 
lighting design, calculation and simulation programs.  The data is provided as 
a complete archive; however, a specific selection according to the technical 
environment and individual product range is also possible. 

Index Of 
Refraction (IOR)  

Index Of Refraction (IOR) is about the way that light passes through different 
types of materials...  diamond, glass, water etc.  When a light ray travels 
through the same volume it follows a straight path.  However if it passes from 
one transparent volume to another, it bends.  This is why a straw in water 
looks bent.  The amount of bending differs between materials.  The angle by 
which the ray is bent can be determined by knowing two things: the angle at 
which the incoming ray has been cast and the Index of Refraction.  This IOR 
value is unique for every material.  Glass has an IOR of about 1.5 and water 
1.3.  By increasing the IOR value for a Kerkythea material, you can control 
how much the environment behind the transparent object is distorted, and 
thus improving the realism of the shader. 

Interpolation  Interpolation is an animation curve: when ticked it will smooth the transitions 
between the camera positions selected in a camera path. 

 

http://en.wikipedia.org/wiki/Focal_length
http://en.wikipedia.org/wiki/Fresnel
http://en.wikipedia.org/wiki/Global_illumination
http://en.wikipedia.org/wiki/Global_illumination
http://en.wikipedia.org/wiki/High_dynamic_range_imaging
http://en.wikipedia.org/wiki/High_dynamic_range_imaging
http://en.wikipedia.org/wiki/High_dynamic_range_imaging
http://en.wikipedia.org/wiki/Refractive_index
http://en.wikipedia.org/wiki/Refractive_index
http://en.wikipedia.org/wiki/Interpolation
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J 
JPEG  JPEG Acronym for Joint Photographic Expert Group (pronounced jay-peg) is 

a commonly used standard method of lossy compression for photographic 
images.  The file format which employs this compression is commonly also 
called JPEG; the most common file extensions for this format are .jpeg, .jfif, 
.jpg, .JPG, or .JPE although .jpg is the most common on all platforms. 

 

K 
Keyframe Keyframe is a frame in an animated sequence of frames that was drawn or 

otherwise constructed directly by the user.  When all frames were drawn by 
animators, the senior artist would draw these frames, leaving the "in between" 
frames to an apprentice.  Now, the animator creates only the first and last 
frames of a simple sequence; the computer fills in the gap. 

 

L 
Luminance Luminance is the density of luminous intensity in a given direction. 

In astronomy, luminosity is the amount of energy a body radiates per unit 
time.  It is typically expressed in the SI units watts, in the cgs units ergs per 
second, or in terms of solar luminosities, Ls; that is, how many times more 
energy the object radiates than the Sun, whose luminosity is 3.827×1026 W. 

 

M 
Motion Blur Motion Blur is the simulation of the phenomenon that occurs when we 

perceive a rapidly moving object.  The object appears to be blurred because 
of our persistence of vision.  Doing motion blur makes computer animation 
appear more realistic.  It can be thought of as adding back some of the time 
dependence expressed in the Rendering Equation. 

 

N 
Normal Mapping  Normal Mapping is similar to Bump Mapping, but instead of the image being a 

greyscale heightmap, the colours define in which direction the normal should 
be shifted, the 3 colour channels being mapped to the 3 directions X, Y and Z.  
This allows more detail and control over the effect. 

 

O 
Opacity . 
 

http://en.wikipedia.org/wiki/JPEG
http://en.wikipedia.org/wiki/Keyframe
http://en.wikipedia.org/wiki/Luminance
http://en.wikipedia.org/wiki/Motion_blur
http://en.wikipedia.org/wiki/Normal_mapping
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P 
Phong  Phong shading term is used indiscriminately to describe both an illumination 

model and an interpolation method in 3D computer graphics.  Phong 
reflection is a local illumination model and can produce a certain degree of 
realism in three-dimensional objects by combining three elements - diffuse, 
specular and ambient for each considered point on a surface. 

Photon mapping Photon mapping is a render method that solves the global illumination 
problem in two passes.  In the first pass, photons are shot from the light 
sources and stored in the computer memory. 
Afterwards, in the ray tracing step, the rays shot from the camera “collect” the 
photons and estimate the perceived brightness. 

Point Light Point Light is a light that has a specific location and radiates equally out in all 
directions.  Examples of point lights would be candles or bare lightbulbs.  
Surfaces close to the point light are brighter than those which are far away.  

Polygon  Polygon is the process of approximating the meta-surface via polygons. 
 

Q 
   
 

R 
Radiosity Radiosity is a more accurate but also more process-intensive technique than 

raytracing, that calculates patterns of light and shadow for rendering graphics 
images from three-dimensional models.  

Radiance Radiance and spectral radiance are radiometric measures that describe the 
amount of light that passes through or is emitted from a particular area, and 
falls within a given solid angle in a specified direction. 
They are used to characterize both emission from diffuse sources and 
reflection from diffuse surfaces. 

Raytracing Raytracing works by tracing the path taken by a ray of light through the scene, 
and calculating reflection, refraction, or absorption of the ray whenever it 
intersects an object in the world. 

Reflection Specular reflection is the mirror-like reflection of light from a surface.  
Specular reflection is accomplished in a ray trace renderer by following a ray 
from the eye to the mirror and then calculating where it bounces from, and 
continuing the process until no surface is found, or a non-reflective surface is 
found.  Specular reflection on a shiny surface like tile, or a wood floor can add 
to the photorealistic effects of a 3D rendering. 

Refraction  Refraction in geometric optics is the change in direction of a wave due to a 
change in velocity.  It happens when waves travel from a medium with a given 
refractive index to a medium with another.  At the boundary between the 
media the wave changes direction; its wavelength increases or decreases but 
frequency remains constant.  For example, a light ray will refract as it enters 
and leaves glass. 

http://en.wikipedia.org/wiki/Phong_shading
http://en.wikipedia.org/wiki/Photon_mapping
http://en.wikipedia.org/wiki/Polygon
http://en.wikipedia.org/wiki/Radiosity
http://en.wikipedia.org/wiki/Radiance
http://en.wikipedia.org/wiki/Raytracing
http://en.wikipedia.org/wiki/Reflection_%28computer_graphics%29
http://en.wikipedia.org/wiki/Refraction
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Specular Specular refers to the perfect, mirror-like reflection of light (or sometimes 

other kinds of wave) from a surface, in which light from a single incoming 
direction (a ray) is reflected into a single outgoing direction. 
Such behavior is described by the law of reflection, which states that the 
direction of incoming light (the incident ray), and the direction of outgoing light 
reflected (the reflected ray) make the same angle with respect to the surface 
normal, thus the angle of incidence equals the angle of reflection; this is 
commonly stated as θi = θr. 
This is in contrast to diffuse reflection, where incoming light is reflected in a 
broad range of directions.  The most familiar example of the distinction 
between specular and diffuse reflection would be glossy and matte paints. 
While both exhibit a combination of specular and diffuse reflection, matte 
paints have a higher proportion of diffuse reflection and glossy paints have a 
greater proportion of specular reflection.  Very highly polished surfaces, such 
as high quality mirrors, can exhibit almost perfect specular reflection. 

Spotlight Spotlight is a light with both location and direction.  A spotlight sends out a 
cone of light defined by the spotlight angle, and illuminates only objects within 
that cone.  Spotlights also have attenuation, as well as a parameter that 
controls whether the spot of light is sharply defined or has smooth edges. 
These 4 types of lights are listed in order of computational complexity; the 
more lights you have the more work the computer has to do. 

Subdivision Subdivision Surface is the tool which subdivides your model. 
A common subdivision algorithm smooths out curves, and allows you to make 
complicated smooth surfaces (eg people, plants, etc) with very few faces. 

Sub Surface 
Scattering (SSS) 

Sub Surface Scattering (SSS) is a mechanism of light transport in which light 
penetrates the surface of a translucent object, is scattered by interacting with 
the material, and exits the surface at a different point.  All non-metallic 
materials are translucent to some degree.  In particular, materials such as 
marble, skin, and milk are extremely difficult to simulate realistically without 
taking subsurface scattering into account. 

 

T 
 Translucent Translucent materials allow light to pass through them only diffusely: they 

cannot be seen through; contrary to popular belief, translucency does not 
include see-through colored objects 

 

U 
UV Mapping (UV) UV Mapping (UV) This refers to the process of re-parameterize a 3D object 

with dimensions X, Y and Z into a 2D plane with coordinates U and V. 
Most texturing requires this step because it tells the program HOW to apply a 
2D image map onto a 3D object.  

 

http://en.wikipedia.org/wiki/Specular
http://en.wikipedia.org/wiki/Subdivision_surface
http://en.wikipedia.org/wiki/Translucent
http://en.wikipedia.org/wiki/UV_Mapping
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V 
Vertex In a polygon, a vertex is called "convex" if the internal angle of the polygon, 

that is, the angle formed by the two edges at the vertex, with the polygon 
inside the angle, is less than π radians; otherwise, it is called "concave" or 
"reflex".  More generally, a vertex of a polyhedron or polytope is convex if the 
intersection of the polyhedron or polytope with a sufficiently small sphere 
centered at the vertex is convex, and concave otherwise. 

 

W 
WIP WIP is Work In Progress. 
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http://en.wikipedia.org/wiki/Vertex_%28geometry%29
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